Сентябрь 25, 2017, 01:44:38 pm

Автор Тема: Проблема с установкой php-imagick  (Прочитано 3408 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Anguis

  • Любопытный
  • **
  • Сообщений: 97
  • Рейтинг помощника: +2/-0
Проблема с установкой php-imagick
« : Февраль 19, 2013, 11:22:21 am »
Здравствуйте!
LAMP стоял с установки системы, и php-imagick тоже, но до сих пор им не приходилось пользоваться. А вот вчера нужно было сделать скрипт для конвертирования изображений. И я с ужасом узрел, что imagick не работает!
'ImagickException' with message 'Unable to read the file

Копался на форумах всяких, в т.ч. и буржуйских и увидел на одном, что могут различаться версии ImageMagick установленного, и того, который пытается использовать пых. Проверил - действительно, ImageMagik стоит 6.8.0 а phpinfo сообщает что использует 6.3.2 Ну я и снес imagick дабы переустановить, что-бы он увидел мою версию ImageMagick. Но не тут-то было! При попытке вновь его установить, получаю вот что:
php-imagick:
 Depends: libMagickCore.so.4  but it is not installable
 Depends: libMagickWand.so.4  but it is not installable

Что делать? В репах этих либ я не нашел! Выручайте! Скрипт писать надо а без работающего php-imagick ни как!!!

Оффлайн Serj

  • Модераторы
  • Гуру форума
  • ***
  • Сообщений: 460
  • Рейтинг помощника: +51/-0
Re: Проблема с установкой php-imagick
« Ответ #1 : Февраль 19, 2013, 02:32:49 pm »
 
Эти библиотеки входят в состав пакета libmagick4, который сейчас в наших репозиториях отсутствует. ???
 
Можно попробовать установить:
http://mirror.internode.on.net/pub/mageia/distrib/1/i586/media/core/release/libmagick4-6.6.6.10-5.mga1.i586.rpm
ftp://ftp.ntua.gr/pub/linux/mandrake/official/2011/i586/media/main/updates/libmagick4-6.7.0.9-1.2-mdv2011.0.i586.rpm
ftp://ftp.sunet.se/pub/Linux/distributions/Mandriva/devel/cooker/i586/media/main/release/libmagick4-6.7.3.1-1-mdv2012.0.i586.rpm
 

Оффлайн Anguis

  • Любопытный
  • **
  • Сообщений: 97
  • Рейтинг помощника: +2/-0
Re: Проблема с установкой php-imagick
« Ответ #2 : Февраль 19, 2013, 06:41:02 pm »
Замучаюсь зависимости собирать
warning: libmagick4-6.7.3.1-1-mdv2012.0.i586.rpm: Header V3 DSA/SHA1 Signature, key ID 26752624: NOKEY
error: Failed dependencies:
        libgraph.so.5 is needed by libmagick4-6.7.3.1-1.i586
        libgvc.so.6 is needed by libmagick4-6.7.3.1-1.i586
        libjbig.so.1 is needed by libmagick4-6.7.3.1-1.i586
        libjpeg.so.8 is needed by libmagick4-6.7.3.1-1.i586
        libstdc++.so.6(GLIBCXX_3.4.15) is needed by libmagick4-6.7.3.1-1.i586

А почему так могло случиться, что php-imagik требует пакет, которого уже нет в системе? Это получается php-imagik устаревший уже? Может можно где-то найти пакет который будет уже с libmagik6 работать? Или как-то подключить старый реп pclinuxos что-бы апт вытянул с него все зависимости?
Ведь в системе у меня есть libMagickCore.so.6 и libMagickWand.so.6 Я пробовал символические ссылки делать, но это не помогло.
Может как-то по-другому установить imagiсk? Я попробовал через pear но в pear imagick нет, нужно подключать pecl, а с этим возникли трудности. команда pear в упор не хочет принимать pecl.php.net. Может imagik собрать как-нть?

Оффлайн Serj

  • Модераторы
  • Гуру форума
  • ***
  • Сообщений: 460
  • Рейтинг помощника: +51/-0

Оффлайн Anguis

  • Любопытный
  • **
  • Сообщений: 97
  • Рейтинг помощника: +2/-0
Re: Проблема с установкой php-imagick
« Ответ #4 : Февраль 19, 2013, 11:24:12 pm »
Здорово! Подключил старый реп, и установилось все прекрасно с него со всеми зависимостями, тока пришлось еще и сам ImageMagick продаунгрейдить, но это все мелочи. Главное - работает!
Обожаю эту Ось!